Send A File & Dropbox
Incident Report for Snap Franchising Ltd
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 21, 2023 - 13:43 AEST
Investigating
We are currently investigating this issue.
Posted Aug 09, 2023 - 19:10 AEST
This incident affects: Snap Website.